Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Getting thumbs files result in frozen in D state (uninterruptible sleep) [NFS Mount] #4195

Closed
benpro opened this issue Sep 22, 2020 · 2 comments
Closed
Labels
bug

Comments

@benpro
Copy link

@benpro benpro commented Sep 22, 2020

Describe the bug

I can watch episodes without issues but thumbs are not loaded.
The thread in charge of getting the thumb got stuck in D state.

System (please complete the following information):

  • OS: Ubuntu 20.04
  • Virtualization: LXC
  • Jellyfin Version: 10.6.4 .deb
  • Storage: NFS

To Reproduce

  1. NFS mount.
  2. Go to an episode.
  3. Thumb not loaded. On Firefox network console, HTTP timeout (by my reverse proxy, otherwise infinite time).

Expected behavior

Thumbs load.

Logs

Sep 22 04:52:41 play jellyfin[1338]: [04:52:41] [DBG] Transmit file /home/jellyfin/Animes/Lucky_Star/[MO-F]Lucky_Star_EP01[BDRip-480p][562FE79B]-thumb.jpg
root@play:/var/lib/jellyfin# ps auwwxhuH p 1338 | grep D
jellyfin    1338  0.0  7.8 4217852 307440 ?      Dsl  04:51   0:00 /usr/bin/jellyfin --webdir=/usr/share/jellyfin/web --restartpath=/usr/lib/jellyfin/restart.sh --ffmpeg=/usr/lib/jellyfin-ffmpeg/ffmpeg

Screenshots

Screenshot_20200922_140343

Additional context

I don't understand why Jellyfin get stuck on these .jpg thumbs. If I open the file, say with hexdump for example, I see no problem getting the file with the NFS share.

root@play:/var/lib/jellyfin# hexdump /home/jellyfin/Animes/Lucky_Star/[MO-F]Lucky_Star_EP01[BDRip-480p][562FE79B]-thumb.jpg -C | less
00000000  ff d8 ff e0 00 10 4a 46  49 46 00 01 01 01 00 48  |......JFIF.....H|
00000010  00 48 00 00 ff db 00 43  00 01 01 01 01 01 01 01  |.H.....C........|
00000020  01 01 01 01 01 01 01 01  01 01 01 01 01 01 01 01  |................|

[…]

After a while, browsing episodes, you can see easily with htop all process in D state.
Screenshot_20200922_141104

@benpro benpro added the bug label Sep 22, 2020
@benpro
Copy link
Author

@benpro benpro commented Sep 22, 2020

Not enabling "Save artwork into media folders" bypass the problem, but I wonder what is the issue with my NFS share…

@benpro
Copy link
Author

@benpro benpro commented Sep 24, 2020

Problem solved on my side.
While stracing, saw:

fcntl(3, F_SETLK, {l_type=F_RDLCK, l_whence=SEEK_SET, l_start=1073741824, l_len=1}) = -1 ENOLCK (No locks available)

It was because my NFS file server was not running rpc-statd service (NFS status monitor for NFSv2/3 locking).

Sorry for the noise!

@benpro benpro closed this Sep 24, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.